about summary refs log tree commit diff
path: root/ops/nixos/camden/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-26T00·17+0000
committerVincent Ambo <tazjin@google.com>2020-05-26T00·17+0000
commit68e384a77f654ed3007bba11c799a850c807bedd (patch)
tree459c90aaa0f3f56fc1c8d1f946261f4d8a932a21 /ops/nixos/camden/default.nix
parent93ba78d6f4632ef1c5228965e3edc8c0faf88c1e (diff)
ffeat(ops/nixos): Add a dummy to make depot available in modules r/853
Because modules are not called via the default depot setup (for now
...), this introduces a dummy module that stores the depot tree itself
in the module configurations.

This makes it possible to write modules that use packages from the
depot.
Diffstat (limited to 'ops/nixos/camden/default.nix')
-rw-r--r--ops/nixos/camden/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/ops/nixos/camden/default.nix b/ops/nixos/camden/default.nix
index 57cc696e4f..9d80059615 100644
--- a/ops/nixos/camden/default.nix
+++ b/ops/nixos/camden/default.nix
@@ -6,6 +6,11 @@ config: let
     config.allowUnfree = true;
   };
 in lib.fix(self: {
+  imports = [
+    ../modules/depot.nix
+  ];
+  depot = depot;
+
   # camden is intended to boot unattended, despite having an encrypted
   # root partition.
   #