about summary refs log tree commit diff
path: root/ops/modules/www/whitby.tvl.fyi.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-02-18T11·32+0300
committertazjin <tazjin@tvl.su>2022-02-18T11·39+0000
commitac6717fe3c5cf5ab6b495092e8dd4565a4242eac (patch)
treec1821ac105febfe6c144420aae2817fa6f21be83 /ops/modules/www/whitby.tvl.fyi.nix
parent5b701ad713072d9910b69396338a816039a810b3 (diff)
fix(ops/modules/www): Make self-redirect to config a generic module r/3849
As suggested by sterni, this makes the self-redirect of a machine to
its configuration a generic module working by convention.

In the process of moving this two small fixes have been applied:

* redirect is only applied if the URI is `/`, this is required for
  ACME to work
* addSSL = true is added, otherwise we have a certificate but no TLS
  listener

Change-Id: Icaef041ff681253a61e36926417bdb2844e3f93d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5313
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--ops/modules/www/whitby.tvl.fyi.nix17
1 files changed, 0 insertions, 17 deletions
diff --git a/ops/modules/www/whitby.tvl.fyi.nix b/ops/modules/www/whitby.tvl.fyi.nix
deleted file mode 100644
index bcd7a76ec4..0000000000
--- a/ops/modules/www/whitby.tvl.fyi.nix
+++ /dev/null
@@ -1,17 +0,0 @@
-# Redirect whitby.tvl.fyi to the machine configuration.
-
-{
-  imports = [
-    ./base.nix
-  ];
-
-  config.services.nginx.virtualHosts."whitby.tvl.fyi" = {
-    serverName = "whitby.tvl.fyi";
-    serverAliases = [ "whitby.tvl.su" ];
-    enableACME = true;
-
-    extraConfig = ''
-      return 302 https://at.tvl.fyi/?q=%2F%2Fops%2Fmachines%2Fwhitby;
-    '';
-  };
-}