about summary refs log tree commit diff
path: root/ops/modules/www/inbox.tvl.su.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-12-24T22·58+0300
committertazjin <tazjin@tvl.su>2022-12-27T19·46+0000
commitd4461434136278f562adec5055ea8d606a1f6d68 (patch)
treef5014b4382e46f8890771b6ffd01fcebe57a18b5 /ops/modules/www/inbox.tvl.su.nix
parenta25c60361e290012d5e81d0f8b3911bf494a4ae0 (diff)
feat(ops/modules): set up public-inbox at inbox.tvl.su r/5503
Initial setup which does not yet include fetching mails at all, this
is for now only going to display a manually populated view of the
existing mailing list while the rest of this stuff is set up.

Change-Id: Ie1235bd257c9056fe37d0740dfca771ebdd880eb
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7628
Reviewed-by: flokli <flokli@flokli.de>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--ops/modules/www/inbox.tvl.su.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/ops/modules/www/inbox.tvl.su.nix b/ops/modules/www/inbox.tvl.su.nix
new file mode 100644
index 0000000000..a9af18e348
--- /dev/null
+++ b/ops/modules/www/inbox.tvl.su.nix
@@ -0,0 +1,24 @@
+{ config, ... }:
+
+{
+  imports = [
+    ./base.nix
+  ];
+
+  config = {
+    services.nginx.virtualHosts."inbox.tvl.su" = {
+      enableACME = true;
+      forceSSL = true;
+
+      extraConfig = ''
+        location = / {
+          return 302 https://inbox.tvl.su/depot;
+        }
+
+        location / {
+          proxy_pass http://localhost:${toString config.services.public-inbox.http.port};
+        }
+      '';
+    };
+  };
+}