about summary refs log tree commit diff
path: root/ops/modules/tvl-buildkite.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-12-19T02·35-0500
committerclbot <clbot@tvl.fyi>2021-12-19T12·58+0000
commit7f593781f3f2c8f0dc2446c11cf3f664f8fb8af4 (patch)
tree972c9a44dd177e4847d3cabf3f5ae79793333c86 /ops/modules/tvl-buildkite.nix
parent23397763a77951f4a3c19ec64b3907139584491f (diff)
feat(whitby): Add buildkite agents to docker group r/3302
I'd like to be able to run extra CI steps that include running docker
containers (to integration test things like webapps that connect to a
database). To do this the buildkite agents themselves need permission to
do docker things.

Change-Id: I3c9a488708f0e12a508754ac41f04148ca7aedac
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4408
Tested-by: BuildkiteCI
Autosubmit: grfn <grfn@gws.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--ops/modules/tvl-buildkite.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/ops/modules/tvl-buildkite.nix b/ops/modules/tvl-buildkite.nix
index 20f8d3bbe4..aaeb5a0f75 100644
--- a/ops/modules/tvl-buildkite.nix
+++ b/ops/modules/tvl-buildkite.nix
@@ -63,7 +63,7 @@ in {
         value = {
           isSystemUser = true;
           group = lib.mkForce "buildkite-agents";
-          extraGroups = [ name ];
+          extraGroups = [ name "docker" ];
         };
       }) agents);
     };