about summary refs log tree commit diff
path: root/ops/modules/tvl-buildkite.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-06T16·19+0300
committertazjin <mail@tazj.in>2021-12-07T18·27+0000
commit6faf0edaff463fd1195e2d5642252a34ea17481a (patch)
tree117877173b6ba5a8a92ef38827e3a53116482ec1 /ops/modules/tvl-buildkite.nix
parent6ef5162a93dc207fb7bd158f9d7449573d05045d (diff)
fix(ops): Correctly pass command name to besadii invocations r/3148
Ensure that besadii sees $0 as the correct command name, since that is
the sole mechanism by which its functionality is switched around.

There was a lingering commit that introduced this bug and hadn't been
deployed in a couple of days. Maybe time to tighten deploy cycles soon
...

Change-Id: Ie4284c0f6e5e06d71a71a3702ec7e092260e0ce5
Diffstat (limited to 'ops/modules/tvl-buildkite.nix')
-rw-r--r--ops/modules/tvl-buildkite.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/ops/modules/tvl-buildkite.nix b/ops/modules/tvl-buildkite.nix
index de14970100..a0236a5e79 100644
--- a/ops/modules/tvl-buildkite.nix
+++ b/ops/modules/tvl-buildkite.nix
@@ -6,16 +6,16 @@ let
   agents = lib.range 1 cfg.agentCount;
   description = "Buildkite agents for TVL";
 
-  besadiiWithConfig = pkgs.writeShellScript "besadii-whitby" ''
+  besadiiWithConfig = name: pkgs.writeShellScript "besadii-whitby" ''
     export BESADII_CONFIG=/etc/secrets/besadii.json
-    exec ${depot.ops.besadii}/bin/besadii
+    exec -a ${name} ${depot.ops.besadii}/bin/besadii "$@"
   '';
 
   # All Buildkite hooks are actually besadii, but it's being invoked
   # with different names.
   buildkiteHooks = pkgs.runCommandNoCC "buildkite-hooks" {} ''
     mkdir -p $out/bin
-    ln -s ${besadiiWithConfig} $out/bin/post-command
+    ln -s ${besadiiWithConfig "post-command"} $out/bin/post-command
   '';
 in {
   options.services.depot.buildkite = {