about summary refs log tree commit diff
path: root/ops/modules/tvl-buildkite.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-10T07·47+0300
committerclbot <clbot@tvl.fyi>2021-12-10T13·14+0000
commitbc3d35f3d0ecffd0b02cc7a7ddea12ae2c63c075 (patch)
tree38dcb4aff2335a71892677f60e9b58200025afa2 /ops/modules/tvl-buildkite.nix
parentd4403638cf02d544d87a0ce9101ee5b18ff09d96 (diff)
fix(tvl-buildkite): Add missing runtimePackages back r/3185
Turns out that the type of this option is not concatenative and it
replaces the packages needed to run Buildkite if set.

Change-Id: I9f52572bc165bccdd8c6518cfdf7b8967f7a50d0
Diffstat (limited to '')
-rw-r--r--ops/modules/tvl-buildkite.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/ops/modules/tvl-buildkite.nix b/ops/modules/tvl-buildkite.nix
index 1f0d4e2e7a..b234913389 100644
--- a/ops/modules/tvl-buildkite.nix
+++ b/ops/modules/tvl-buildkite.nix
@@ -34,8 +34,12 @@ in {
         inherit name;
         enable = true;
         tokenPath = "/run/agenix/buildkite-agent-token";
-        runtimePackages = with pkgs; [ curl jq ];
         hooks.post-command = "${buildkiteHooks}/bin/post-command";
+
+        runtimePackages = with pkgs; lib.mkAfter [
+          curl
+          jq
+        ];
       };
     }) agents);