about summary refs log tree commit diff
path: root/ops/modules/monorepo-gerrit.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-09-18T14·44+0300
committertazjin <mail@tazj.in>2021-09-18T15·10+0000
commit0e3858b5e5bb5717319c5a17fb195c51f1cbf06c (patch)
tree4219e1df539b522fae35f1007b32e0cbe955c740 /ops/modules/monorepo-gerrit.nix
parent86a114ac458861b60ae67252ffe056f4cfc2f328 (diff)
refactor(whitby): Move restic path configuration into modules r/2890
This lets each service declare their backup paths together with the
configuration for the service, which is a lot more sensible than what
we had before.

Fixes b/147

Change-Id: If76fe62639f4cc0e6fbb63a2959d584479d8f0fb
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3583
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'ops/modules/monorepo-gerrit.nix')
-rw-r--r--ops/modules/monorepo-gerrit.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/ops/modules/monorepo-gerrit.nix b/ops/modules/monorepo-gerrit.nix
index d4b37d860b..69850fa15a 100644
--- a/ops/modules/monorepo-gerrit.nix
+++ b/ops/modules/monorepo-gerrit.nix
@@ -135,4 +135,9 @@ in {
       Group = "git";
     };
   };
+
+  services.depot.restic = {
+    paths = [ "/var/lib/gerrit" ];
+    exclude = [ "/var/lib/gerrit/tmp" ];
+  };
 }