about summary refs log tree commit diff
path: root/ops/machines/whitby/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-13T08·15+0300
committerclbot <clbot@tvl.fyi>2022-01-13T08·39+0000
commitbce519256641d200b6f80711fa3081e89f0e6b93 (patch)
treedeb7f4789691e79e586a50e1c8159e69bb617c86 /ops/machines/whitby/default.nix
parent9c025d62a067756d1f32c07ff4dc485942368c6f (diff)
feat(whitby): Install a handful of systemPackages r/3590
Adds more things I keep using via nix-shell, as well as the
deploy-whitby script (which is independent of a particular depot
checkout).

Change-Id: I36f87de7645768a05268c90ba9b3ab833bacca05
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4881
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'ops/machines/whitby/default.nix')
-rw-r--r--ops/machines/whitby/default.nix18
1 files changed, 13 insertions, 5 deletions
diff --git a/ops/machines/whitby/default.nix b/ops/machines/whitby/default.nix
index 22d85b763b..dbee33aa3f 100644
--- a/ops/machines/whitby/default.nix
+++ b/ops/machines/whitby/default.nix
@@ -445,24 +445,32 @@ in {
 
   services.fail2ban.enable = true;
 
-  environment.systemPackages = with pkgs; [
+  environment.systemPackages = (with pkgs; [
+    alacritty.terminfo
+    bat
     bb
     curl
     direnv
     emacs-nox
+    fd
+    foot.terminfo
     git
     htop
+    hyperfine
     jq
+    kitty.terminfo
     nano
+    nvd
     ripgrep
     rxvt_unicode.terminfo
-    foot.terminfo
-    kitty.terminfo
-    alacritty.terminfo
+    tree
+    unzip
     vim
     zfs
     zfstools
-  ];
+  ]) ++ (with depot; [
+    ops.deploy-whitby
+  ]);
 
   services.journaldriver = {
     enable = true;