about summary refs log tree commit diff
path: root/ops/machines/whitby/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-05-22T13·22+0200
committertazjin <mail@tazj.in>2021-05-22T17·57+0000
commit814feed0ce02f9d2f3597fa3bc56bd193a6c740d (patch)
tree8e67753a5f9db77cb7971b24766e2053d4294736 /ops/machines/whitby/default.nix
parenta7b168ec9a96d5fbd3aa4dc271f972e767e1758b (diff)
chore(whitby): Move clbot to HackInt r/2604
Points clbot at the new local ZNC instead. This will make it part of
the things happening through the `tvlbot` account.

Relates to b/101

Change-Id: I1c15ffa5720d3af34475c15bee3fdaa537ac659b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3127
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'ops/machines/whitby/default.nix')
-rw-r--r--ops/machines/whitby/default.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/ops/machines/whitby/default.nix b/ops/machines/whitby/default.nix
index 36b4a19875..d8594c43fb 100644
--- a/ops/machines/whitby/default.nix
+++ b/ops/machines/whitby/default.nix
@@ -247,14 +247,17 @@ in {
   # Start the Gerrit->IRC bot
   services.depot.clbot = {
     enable = true;
+    channels = [ "#tvl" ];
 
-    # Almost all configuration values are already correct (well, duh),
-    # see //fun/clbot for details.
+    # See //fun/clbot for details.
     flags = {
       gerrit_host = "cl.tvl.fyi:29418";
       gerrit_ssh_auth_username = "clbot";
-      gerrit_ssh_auth_key = "/etc/secrets/clbot-key";
-      irc_server = "znc.lukegb.com:6697";
+      gerrit_ssh_auth_key = "/etc/secrets/id_clbot";
+
+      irc_server = "localhost:${toString config.services.znc.config.Listener.l.Port}";
+      irc_user = "tvlbot";
+      irc_nick = "tvlbot";
 
       notify_branches = "canon,refs/meta/config";
       notify_repo = "depot";
@@ -263,11 +266,6 @@ in {
       # populated from /etc/secrets/clbot
       irc_pass = "$CLBOT_PASS";
     };
-
-    channels = [
-      "##tvl"
-      "##tvl-dev"
-    ];
   };
 
   services.depot = {