about summary refs log tree commit diff
path: root/ops/keycloak/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-12-26T00·08+0300
committerclbot <clbot@tvl.fyi>2021-12-26T16·45+0000
commit7b3c0b3e2f672ba2547827105b9f14d003d16267 (patch)
treecb37cae2cfcf9e5845b2d64bbfdb7ae1f3734f22 /ops/keycloak/default.nix
parent8a5ccd70899b6c17f5e3947a1edf1d5084d28cd2 (diff)
feat(ops/keycloak): Check in initial Keycloak configuration r/3425
This is still missing most of the client configuration etc., in part
due to bugs in the provider which are preventing resource imports.

Change-Id: Ic224ffc001f8e1fe6dcd47b7d002580fdf7b0774
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4628
Tested-by: BuildkiteCI
Autosubmit: tazjin <mail@tazj.in>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'ops/keycloak/default.nix')
-rw-r--r--ops/keycloak/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/ops/keycloak/default.nix b/ops/keycloak/default.nix
new file mode 100644
index 0000000000..96f0c40e5e
--- /dev/null
+++ b/ops/keycloak/default.nix
@@ -0,0 +1,8 @@
+{ depot, pkgs, ... }:
+
+depot.nix.readTree.drvTargets {
+  # Provide a Terraform wrapper with the right provider installed.
+  terraform = pkgs.terraform.withPlugins(p: [
+    p.keycloak
+  ]);
+}