about summary refs log tree commit diff
path: root/ops/besadii/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-13T22·38+0000
committerVincent Ambo <tazjin@google.com>2020-02-21T22·05+0000
commit80c6680eda2afd2e9899f92d508d1b1907916756 (patch)
treef48a940ef57fc516661a3ce29c2b483352bd7b2e /ops/besadii/default.nix
parentd657e878fa518cd0489ee6352261bf17185c3fe4 (diff)
feat(ops/besadii): Refactored tool to trigger sourcehut builds
Refactors //ops/sync-gcsr which was previously responsible for
synchronising the git repository between GCSR and the git.tazj.in cgit
instance to simply be responsible for triggering builds on sourcehut.

This program is intended to run as a git post-update hook.

Note: Not yet feature complete, as interpolation of concrete git
values and also sourcehut secrets is missing.
Diffstat (limited to 'ops/besadii/default.nix')
-rw-r--r--ops/besadii/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/ops/besadii/default.nix b/ops/besadii/default.nix
new file mode 100644
index 0000000000..fc7b2286c7
--- /dev/null
+++ b/ops/besadii/default.nix
@@ -0,0 +1,8 @@
+# This program is used as a git post-update hook to trigger builds on
+# sourcehut.
+{ depot, ... }:
+
+depot.buildGo.program {
+  name = "besadii";
+  srcs = [ ./main.go ];
+}