about summary refs log tree commit diff
path: root/ops/besadii/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-21T23·17+0000
committerVincent Ambo <tazjin@google.com>2020-02-21T23·17+0000
commit892418db8f291efa184e2130533dfab3f2f91f40 (patch)
tree52005bbd2226c75137f206c93ec16a65d864dfcc /ops/besadii/default.nix
parentd657e878fa518cd0489ee6352261bf17185c3fe4 (diff)
parent5ed68f0f6b192cffb1bd4d1790360583d08018bb (diff)
merge(feat/besadii): Integrate besadii at //ops/besadii r/569
This tool supersedes the previous //ops/sync-gcsr, which no longer
exists.

Besadii runs as a git post-receive hook and triggers builds for the
depot on sourcehut. Builds are only triggered for branches, not for
tags.

The sourcehut token is read from /etc/secrets where it has been
manually placed on camden.

Besadii was a hutt kajidic, and also part of the Hutt Clan.
Diffstat (limited to 'ops/besadii/default.nix')
-rw-r--r--ops/besadii/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/ops/besadii/default.nix b/ops/besadii/default.nix
new file mode 100644
index 000000000000..31f2705d7327
--- /dev/null
+++ b/ops/besadii/default.nix
@@ -0,0 +1,12 @@
+# This program is used as a git post-update hook to trigger builds on
+# sourcehut.
+{ depot, ... }:
+
+depot.buildGo.program {
+  name = "besadii";
+  srcs = [ ./main.go ];
+
+  x_defs = {
+    "main.gitBin" = "${depot.third_party.git}/bin/git";
+  };
+}