about summary refs log tree commit diff
path: root/nixos/socrates/hardware.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-17T08·48+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commit7833632a7961038e8898ef287fd2dedf8fa7f33b (patch)
tree2c7cc90e0eda2900314fdec02bbfddc1b55f7f1e /nixos/socrates/hardware.nix
parent51cdb872237c86f33a14a845f62a6ee5f267bed6 (diff)
Attempt nix-build instead of nixos-rebuild switch
I've encountered a few problems with attempting to support nixos-rebuild:
- the activation step requires `sudo` privileges
- the `buildkite-agent` runs on the same machine, socrates, that is rebuilding
  itself. This means that when the activation step runs, it will attempt to
  restart `buildkite-agent` when the agent is still working

I'm slowly removing places in my nix code that rely on '<bracket>' notation, so
that I no longer depend on NIX_PATH being set. I still have more work to do.

{covid-uk,sandbox}/default.nix are breaking when I attempt to run my
build-socrates.sh script locally, so I'm temporarily disabling them until I can
get CI working as I expect.
Diffstat (limited to 'nixos/socrates/hardware.nix')
-rw-r--r--nixos/socrates/hardware.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/socrates/hardware.nix b/nixos/socrates/hardware.nix
index dde14eb1e627..d13ffd7e401d 100644
--- a/nixos/socrates/hardware.nix
+++ b/nixos/socrates/hardware.nix
@@ -5,7 +5,7 @@
 
 {
   imports =
-    [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+    [ /home/wpcarro/nixpkgs/nixos/modules/installer/scan/not-detected.nix
     ];
 
   boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "usbhid" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];