about summary refs log tree commit diff
path: root/nixos/socrates/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-09-01T11·17+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-09-01T11·17+0100
commit3fb9324c82b02fa6dfd7c293f2fd8a4a054acdf0 (patch)
tree4b566c995ac5383b7ff635605959db60c91d6e1b /nixos/socrates/default.nix
parenta0760279452b128ef815b0492489b6d550156f0a (diff)
Delete comment monzo_ynab deployment
I haven't used this since I wrote it months ago...
Diffstat (limited to '')
-rw-r--r--nixos/socrates/default.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/nixos/socrates/default.nix b/nixos/socrates/default.nix
index ec0bf3a73dc5..8b762a56de5f 100644
--- a/nixos/socrates/default.nix
+++ b/nixos/socrates/default.nix
@@ -1,8 +1,6 @@
 let
   briefcase = import <briefcase> {};
   pkgs = briefcase.third_party.pkgs;
-  trimNewline = x: pkgs.lib.removeSuffix "\n" x;
-  readSecret = x: trimNewline (builtins.readFile ("/etc/secrets/" + x));
 in {
   imports = [ ./hardware.nix ];
 
@@ -116,26 +114,6 @@ in {
     };
   };
 
-  # systemd.services.monzo-token-server = {
-  #   enable = true;
-  #   description = "Ensure my Monzo access token is valid";
-  #   script = "${briefcase.tools.monzo_ynab.tokens}/bin/token-server";
-  #   # TODO(wpcarro): I'm unsure of the size of this security risk, but if a
-  #   # non-root user runs `systemctl cat monzo-token-server`, they could read the
-  #   # following, sensitive environment variables.
-  #   environment = {
-  #     store_path = "/var/cache/monzo_ynab";
-  #     monzo_client_id = readSecret "monzo-client-id";
-  #     monzo_client_secret = readSecret "monzo-client-secret";
-  #     ynab_personal_access_token = readSecret "ynab-personal-access-token";
-  #     ynab_account_id = readSecret "ynab-account-id";
-  #     ynab_budget_id = readSecret "ynab-budget-id";
-  #   };
-  #   serviceConfig = {
-  #     Type = "simple";
-  #   };
-  # };
-
   systemd.services.zoo = {
     enable = true;
     description = "Run my monoserver";