about summary refs log tree commit diff
path: root/nixos/installer.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-20T19·51+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-20T19·51+0000
commit79013316a600cec7ef89ba0c077f2bec16dbee0d (patch)
tree88a120b3565cd3ed71a4fce5a59d5feccad495eb /nixos/installer.nix
parent01f0ebfa324dda0a76743cbd50547aa49148afaf (diff)
Support installer.nix
The command...
nix-build -A config.system.build.isoImage -I nixos-config=installer.nix nixos
...creates an .iso file in the ./result directory. You can then copy this onto a
USB and use it a custom installer...
cp ./result/iso/*-linux.iso /dev/sda

I needed an installer that used a version of the Linux kernel higher than the
one distributed on NixOS's website: 4.19.? -> 5.4.20+. My Acer laptop needed a
version of the kernel that supported its network controller: Intel 3168NGW.

TODO(wpcarro): Pin the nixpkgs git commit SHA inside of installer.nix.
Diffstat (limited to 'nixos/installer.nix')
-rw-r--r--nixos/installer.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/nixos/installer.nix b/nixos/installer.nix
new file mode 100644
index 000000000000..f0c1efe21ef5
--- /dev/null
+++ b/nixos/installer.nix
@@ -0,0 +1,11 @@
+{ config, pkgs, ...  }:
+
+{
+  imports = [
+    <nixpkgs/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix>
+  ];
+  config = {
+    networking.wireless.enable = true;
+    networking.wireless.networks."GoogleGuest" = {};
+  };
+}