about summary refs log tree commit diff
path: root/nixos/installer.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-22T18·44+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-22T18·44+0000
commit695de12482044badda02088eea24c02598e18382 (patch)
treec179959f190ef26b87e1d5fcd57349cc189bb67d /nixos/installer.nix
parentb53ae61db2228022cbe9883b539bd90eb07c96a8 (diff)
Incorporate NixOS configuration
TL;DR:
- Move /etc/nixos/configuration.nix -> //nixos/configuration.nix
- Move /etc/nixos/hardware-configuration.nix -> //nixos/harware.nix
- Document installer.nix
- Create rebuild.nix wrapper around `sudo nixos-rebuild switch`

Previously I sketched ideas for the configuration.nix for socrates -- also known
as flattop -- the inexpensive Acer laptop residing in my flat and stored that
configuration.nix file in briefcase. Now, however, I have successfully installed
NixOS onto socrates. By default NixOS saves the configuration.nix and
hardware-configuration.nix files to /etc/nixos/. I'm moving both of these files
into briefcase.

Because the command `nixos-rebuild` looks for the NixOS configuration
file in /etc/nixos, I wrote rebuild.nix, which creates a program to
call `nixos-rebuild` with the new location of my configuration.nix.
Diffstat (limited to 'nixos/installer.nix')
-rw-r--r--nixos/installer.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/installer.nix b/nixos/installer.nix
index f0c1efe21ef5..276b1f60df49 100644
--- a/nixos/installer.nix
+++ b/nixos/installer.nix
@@ -1,3 +1,4 @@
+# This expression can be used to create NixOS .iso images.
 { config, pkgs, ...  }:
 
 {