about summary refs log tree commit diff
path: root/nix/yants/tests/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T21·52+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T21·53+0000
commit9885036eec80305fcd44b51a1878e7118282db78 (patch)
treea7f814caba2128f46502fbcb845f70fc5d912452 /nix/yants/tests/default.nix
parent902500c4ead7166274187dcb776048d2ecd86bfa (diff)
chore(yants): Move tests into subfolder & add to CI builds r/250
Diffstat (limited to '')
-rw-r--r--nix/yants/tests/default.nix (renamed from nix/yants/tests.nix)6
1 files changed, 4 insertions, 2 deletions
diff --git a/nix/yants/tests.nix b/nix/yants/tests/default.nix
index 6863ced066..ae144db45a 100644
--- a/nix/yants/tests.nix
+++ b/nix/yants/tests/default.nix
@@ -1,5 +1,7 @@
+{ pkgs, ... }:
+
 with builtins;
-with (import ./default.nix {});
+with pkgs.nix.yants;
 
 # Note: Derivations are not included in the tests below as they cause
 # issues with deepSeq.
@@ -89,4 +91,4 @@ deepSeq rec {
     (struct { a = int; b = option string; })
     (sum { a = int; b = option string; })
   ];
-} "All tests passed!\n"
+} (pkgs.writeText "yants-tests" "All tests passed!")