about summary refs log tree commit diff
path: root/nix/utils/tests/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-11-08T10·04+0000
committersterni <sternenseemann@systemli.org>2022-11-09T15·36+0000
commit19ddb1466e09cbac4f288c1f26a7b23584cf7447 (patch)
treeb0c81e439f286e5a0daba7db1684cc48a1f00615 /nix/utils/tests/default.nix
parent41883b6c08f648b58fdf2f37f8307fa208993570 (diff)
revert(nix/utils): onlyDrvPath to get the drvPath w/o the outputs r/5274
This reverts commit 6813598c17959862734e5878d745e7dd8a197717.

Reason for revert: This function is a re-implementation of
builtins.unsafeDiscardOutputDependency which I missed at the time.

Change-Id: I5bb52bfd5e8d51defaf90ee795b0fe99be84f6db
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7265
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to '')
-rw-r--r--nix/utils/tests/default.nix11
1 files changed, 0 insertions, 11 deletions
diff --git a/nix/utils/tests/default.nix b/nix/utils/tests/default.nix
index d5159a8433..344a1771d7 100644
--- a/nix/utils/tests/default.nix
+++ b/nix/utils/tests/default.nix
@@ -15,7 +15,6 @@ let
     isSymlink
     pathType
     storePathName
-    onlyDrvPath
     ;
 
   assertUtilsPred = msg: act: exp: [
@@ -92,19 +91,9 @@ let
       (storePathName cleanedSource)
       cleanedSource.name)
   ];
-
-  onlyDrvPathTests = it "correctly updates the string context of drvPath" [
-    (assertEq "onlyDrvPath only produces path dependencies"
-      (builtins.all
-        (dep: dep.path or false)
-        (builtins.attrValues
-          (builtins.getContext (onlyDrvPath depot.tools.cheddar))))
-      true)
-  ];
 in
 
 runTestsuite "nix.utils" [
   pathPredicates
   storePathNameTests
-  onlyDrvPathTests
 ]