about summary refs log tree commit diff
path: root/nix/docs.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-15T07·20+0100
committerVincent Ambo <mail@tazj.in>2020-07-15T07·20+0100
commit7f19d641647ac4ef313ed88d6b5c140983ce5436 (patch)
tree31b66c81465293da5c093c5dde3e419758c0d6cc /nix/docs.nix
Squashed 'third_party/immer/' content from commit ad3e3556d
git-subtree-dir: third_party/immer
git-subtree-split: ad3e3556d38bb75966dd24c61a774970a7c7957e
Diffstat (limited to 'nix/docs.nix')
-rw-r--r--nix/docs.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/nix/docs.nix b/nix/docs.nix
new file mode 100644
index 000000000000..f885e6d9e177
--- /dev/null
+++ b/nix/docs.nix
@@ -0,0 +1,27 @@
+{ nixpkgs ? <nixpkgs>}:
+
+with import nixpkgs {};
+
+rec {
+  breathe = with python27Packages; buildPythonPackage rec {
+    version = "git-arximboldi-${commit}";
+    pname = "breathe";
+    name = "${pname}-${version}";
+    commit = "5074aecb5ad37bb70f50216eaa01d03a375801ec";
+    src = fetchFromGitHub {
+      owner = "arximboldi";
+      repo = "breathe";
+      rev = commit;
+      sha256 = "10kkh3wb0ggyxx1a7x50aklhhw0cq269g3jddf2gb3pv9gpbj7sa";
+    };
+    propagatedBuildInputs = [ docutils sphinx ];
+    meta = with stdenv.lib; {
+      homepage = https://github.com/michaeljones/breathe;
+      license = licenses.bsd3;
+      description = "Sphinx Doxygen renderer";
+      inherit (sphinx.meta) platforms;
+    };
+  };
+
+  recommonmark = python27Packages.recommonmark;
+}