about summary refs log tree commit diff
path: root/net/crimp/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-08-15T14·16+0300
committertazjin <mail@tazj.in>2021-08-15T14·18+0000
commit509ea7f3cb0d29a9348b2d552445f9ee501de851 (patch)
tree19aae039654740ae447ef99392c1683a4548111e /net/crimp/default.nix
parentdb5ba287352a5a12f8aef80632a3ac18862ce3af (diff)
feat(crimp): Add Nix build for crate r/2738
... mostly to get CI.

Note that this adds the Cargo.lock file because we require pinning,
but it is generally not required for Rust libraries.

Change-Id: I565c7c8e899694accf3efd825ff46225f3c47d1a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3363
Reviewed-by: tazjin <mail@tazj.in>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--net/crimp/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/net/crimp/default.nix b/net/crimp/default.nix
new file mode 100644
index 0000000000..c6b84fb7ab
--- /dev/null
+++ b/net/crimp/default.nix
@@ -0,0 +1,9 @@
+{ depot, pkgs, ... }:
+
+depot.third_party.naersk.buildPackage {
+  src = ./.;
+  buildInputs = with pkgs; [
+    openssl
+    pkgconfig
+  ];
+}