about summary refs log tree commit diff
path: root/lisp/dns/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-22T18·04+0000
committerVincent Ambo <tazjin@google.com>2020-01-22T18·04+0000
commite50c362244be69c12a6d4f320c6ca00475d2de34 (patch)
tree6cda941b2f2d9c66a3b935e8b9a369f0b5d2ca21 /lisp/dns/default.nix
parent98cc5f9fac9c2739e08486548a4c678e8d48965b (diff)
feat(lisp/dns): Check in very early DNS-over-HTTPS client r/448
This includes very barebones support for querying TXT and MX records
right now. The returned structure is not turned into a more convenient
format and error handling is, well, NIL.
Diffstat (limited to 'lisp/dns/default.nix')
-rw-r--r--lisp/dns/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/lisp/dns/default.nix b/lisp/dns/default.nix
new file mode 100644
index 0000000000..c41b02f97c
--- /dev/null
+++ b/lisp/dns/default.nix
@@ -0,0 +1,15 @@
+{ pkgs, ... }:
+
+pkgs.nix.buildLisp.library {
+  name = "dns";
+
+  deps = with pkgs.third_party.lisp; [
+    alexandria
+    cl-json
+    drakma
+  ];
+
+  srcs = [
+    ./resolver.lisp
+  ];
+}