about summary refs log tree commit diff
path: root/infra/nixos/pkgs/gemma.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-09-02T16·15+0100
committerVincent Ambo <tazjin@google.com>2019-09-02T16·19+0100
commit4881a84eaafc1e5ea5d5d76f14cfe8c5b233791f (patch)
treeae48379aecbd86329a338fd5f5475b44a27a1a20 /infra/nixos/pkgs/gemma.nix
parent4bd6d528008c6a8a7357a2c40013931800582252 (diff)
chore(infra): Remove NixOS configuration for servers
This configuration is no longer in use. The Gemma configuration file
has been moved over to the k8s folder from where it will be templated
into the actual configuration.
Diffstat (limited to 'infra/nixos/pkgs/gemma.nix')
-rw-r--r--infra/nixos/pkgs/gemma.nix54
1 files changed, 0 insertions, 54 deletions
diff --git a/infra/nixos/pkgs/gemma.nix b/infra/nixos/pkgs/gemma.nix
deleted file mode 100644
index 4e96734794ff..000000000000
--- a/infra/nixos/pkgs/gemma.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-{ pkgs ? import <nixpkgs> {} }:
-
-with pkgs; stdenv.mkDerivation rec {
-  name = "gemma";
-
-  src = fetchFromGitHub {
-    owner  = "tazjin";
-    repo   = "gemma";
-    rev    = "61be253d6baa99f0a2208425b8a03b444bb1b184";
-    sha256 = "0vbmz2aphcida728rc0z3k7gychs4w1778vsjbrs0ljk9qgbmyr5";
-  };
-
-  buildInputs = with lispPackages; [
-    sbcl
-    quicklisp
-    hunchentoot
-    cl-json
-    local-time
-    elmPackages.elm
-    pkgconfig
-  ];
-
-  # The build phase has three distinct things it needs to do:
-  #
-  # 1. "Compile" the Elm source into something useful to browsers.
-  #
-  # 2. Configure the Lisp part of the application to serve the compiled Elm
-  #
-  # 3. Build (and don't strip!) an executable out of the Lisp backend.
-  buildPhase = ''
-    mkdir -p $out/share/gemma $out/bin
-    mkdir .home && export HOME="$PWD/.home"
-
-    # Build Elm
-    cd frontend
-    elm-make --yes Main.elm --output $out/share/gemma/index.html
-
-    # Build Lisp
-    cd $src
-    quicklisp init
-    env GEMMA_BIN_TARGET=$out/bin/gemma sbcl --load build.lisp
-  '';
-
-  installPhase = "true";
-
-  # Stripping an SBCL executable removes the application, which is unfortunate.
-  dontStrip = true;
-
-  meta = with stdenv.lib; {
-    description = "Tool for tracking recurring tasks";
-    homepage    = "https://github.com/tazjin/gemma";
-    license     = licenses.gpl3;
-  };
-}