about summary refs log tree commit diff
path: root/infra/nixos/glesys.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-07-02T11·48+0100
committerVincent Ambo <tazjin@google.com>2019-07-02T11·48+0100
commita131b3051428d3abe220d172f93d09880b96222f (patch)
tree2ba11e900c675d3d2ad39e713554b3a6e2f10d1d /infra/nixos/glesys.nix
parent1109e449efbc9a0dab8c4e88e07337a318e21f09 (diff)
refactor(infra): Move infrastructure into monorepo structure
Diffstat (limited to 'infra/nixos/glesys.nix')
-rw-r--r--infra/nixos/glesys.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/infra/nixos/glesys.nix b/infra/nixos/glesys.nix
new file mode 100644
index 0000000000..4cd66cb195
--- /dev/null
+++ b/infra/nixos/glesys.nix
@@ -0,0 +1,18 @@
+{
+  sto-tazserve-1 = { pkgs, config, ... }: {
+    deployment.targetHost = "46.21.106.241";
+
+    # Configure network
+    networking.hostName = "sto-tazserve-1";
+    networking.interfaces.ens32.ip4 = [
+      { address = "46.21.106.241"; prefixLength = 23; }
+    ];
+    networking.defaultGateway = "46.21.106.1";
+    networking.nameservers = [ "195.20.206.80" "195.20.206.81" ];
+
+    imports = [
+      ./configuration.nix
+      ./tazserve.nix
+    ];
+  };
+}