about summary refs log tree commit diff
path: root/infra/nixos/dotfiles.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
commit03bfe08e1dd9faf48b06cb146bfa446575cde88a (patch)
tree55317968922a9b2a01516f1b79527874df037517 /infra/nixos/dotfiles.nix
parente52eed3cd4f73779c2e7c350537fb346835ba9f3 (diff)
chore: Significantly restructure folder layout r/237
This moves the various projects from "type-based" folders (such as
"services" or "tools") into more appropriate semantic folders (such as
"nix", "ops" or "web").

Deprecated projects (nixcon-demo & gotest) which only existed for
testing/demonstration purposes have been removed.

(Note: *all* builds are broken with this commit)
Diffstat (limited to 'infra/nixos/dotfiles.nix')
-rw-r--r--infra/nixos/dotfiles.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/infra/nixos/dotfiles.nix b/infra/nixos/dotfiles.nix
deleted file mode 100644
index 2e952207d47d..000000000000
--- a/infra/nixos/dotfiles.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-# Bundle configuration files into a derivation.
-# I call this derivation dotfiles despite that not technically being true
-# anymore ...
-
-{ config, pkgs, ...}:
-
-let dotfiles = pkgs.stdenv.mkDerivation {
-  name = "tazjins-dotfiles";
-
-  srcs = [
-    ./dotfiles
-  ];
-
-  installPhase = ''
-    mkdir -p $out
-    cp ./* $out/
-  '';
-};
-in {
-  # /etc/ is a special place in NixOS!
-  # Symlinks that need to be created there must be specified explicitly.
-  environment.etc = {
-    "alacritty.yml".source    = "${dotfiles}/alacritty.yml";
-    "fish/config.fish".source = "${dotfiles}/config.fish";
-    "tmux.conf".source        = "${dotfiles}/tmux.conf";
-  };
-}