about summary refs log tree commit diff
path: root/infra/nixos/configuration.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-09-02T16·15+0100
committerVincent Ambo <tazjin@google.com>2019-09-02T16·19+0100
commit4881a84eaafc1e5ea5d5d76f14cfe8c5b233791f (patch)
treeae48379aecbd86329a338fd5f5475b44a27a1a20 /infra/nixos/configuration.nix
parent4bd6d528008c6a8a7357a2c40013931800582252 (diff)
chore(infra): Remove NixOS configuration for servers
This configuration is no longer in use. The Gemma configuration file
has been moved over to the k8s folder from where it will be templated
into the actual configuration.
Diffstat (limited to 'infra/nixos/configuration.nix')
-rw-r--r--infra/nixos/configuration.nix53
1 files changed, 0 insertions, 53 deletions
diff --git a/infra/nixos/configuration.nix b/infra/nixos/configuration.nix
deleted file mode 100644
index 1de11a16f9b6..000000000000
--- a/infra/nixos/configuration.nix
+++ /dev/null
@@ -1,53 +0,0 @@
-# This file contains basic configuration for all *.tazj.in Nix machines.
-
-{ config, pkgs, ... }:
-
-{
-  boot.loader.grub.enable = true;
-  boot.loader.grub.version = 2;
-  boot.loader.grub.device = "/dev/sda";
-
-  boot.initrd.availableKernelModules = [
-    "ata_piix"
-    "mptspi"
-    "sd_mod"
-    "sr_mod"
-  ];
-
-  # Configure root disk
-  fileSystems."/" = {
-    device = "/dev/disk/by-label/nixos";
-    fsType = "ext4";
-  };
-
-  services.vmwareGuest.enable = true;
-  services.vmwareGuest.headless = true;
-
-  time.timeZone = "Europe/Oslo";
-
-  environment.systemPackages = with pkgs; [
-    curl emacs htop
-  ];
-
-  services.openssh.enable = true;
-
-  networking.firewall.enable = true;
-  networking.firewall.allowedTCPPorts = [ 22 80 443 ];
-
-  users.extraUsers.vincent = {
-    isNormalUser = true;
-    uid = 1000;
-    extraGroups = [ "wheel" ];
-  };
-
-  security.sudo = {
-    enable = true;
-    extraConfig = "%wheel ALL=(ALL) NOPASSWD: ALL";
-  };
-
-  # This value determines the NixOS release with which your system is to be
-  # compatible, in order to avoid breaking some software such as database
-  # servers. You should change this only after NixOS release notes say you
-  # should.
-  system.stateVersion = "17.09"; # Did you read the comment?
-}