about summary refs log tree commit diff
path: root/home/platforms/linux.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
commit9036dc7c32739d302cdd6fe51fe2d01418a99c9d (patch)
tree2f67188616193c8b9b3de011d0bc546aca68a5ee /home/platforms/linux.nix
parent86b5f58ca51bfb91de4cd29e66b781d5e035db7a (diff)
Beginnings of config for Darwin machines
Split out a platforms/ directory with a linux.nix and darwin.nix, and
starting splitting things out between the two
Diffstat (limited to 'home/platforms/linux.nix')
-rw-r--r--home/platforms/linux.nix103
1 files changed, 103 insertions, 0 deletions
diff --git a/home/platforms/linux.nix b/home/platforms/linux.nix
new file mode 100644
index 0000000000..b49193442b
--- /dev/null
+++ b/home/platforms/linux.nix
@@ -0,0 +1,103 @@
+{ config, pkgs, ... }:
+
+{
+  imports = [
+    ../modules/alacritty.nix
+    ../modules/alsi.nix
+    ../modules/development.nix
+    ../modules/emacs.nix
+    ../modules/email.nix
+    ../modules/firefox.nix
+    ../modules/games.nix
+    ../modules/obs.nix
+    ../modules/i3.nix
+    ../modules/shell.nix
+    ../modules/tarsnap.nix
+    ../modules/vim.nix
+
+    ~/code/urb/urbos/home
+
+    machine
+  ];
+
+  xsession.enable = true;
+
+  home.packages = with pkgs; [
+    (import (fetchTarball "https://github.com/ashkitten/nixpkgs/archive/init-glimpse.tar.gz") {}).glimpse
+
+    # Desktop stuff
+    arandr
+    firefox
+    feh
+    chromium
+    xclip
+    xorg.xev
+    picom
+    peek
+    signal-desktop
+    apvlv # pdf viewer
+    vlc
+    irssi
+    gnutls
+    pandoc
+    barrier
+
+    # System utilities
+    powertop
+    usbutils
+    pciutils
+    gdmap
+    lsof
+    tree
+    ncat
+
+    # Security
+    gnupg
+    keybase
+    openssl
+
+    # Spotify...etc
+    spotify
+    playerctl
+  ];
+
+  nixpkgs.config.allowUnfree = true;
+
+  programs.password-store.enable = true;
+
+  services.redshift = {
+    enable = true;
+    provider = "geoclue2";
+  };
+
+  services.pasystray.enable = true;
+
+  impure.clonedRepos.passwordStore = {
+    github = "glittershark/pass";
+    path = ".local/share/password-store";
+  };
+
+  urbint.projectPath = "code/urb";
+
+  services.gpg-agent = {
+    enable = true;
+  };
+
+  gtk = {
+    enable = true;
+    gtk3.bookmarks = [
+      "file:///home/grfn/code"
+    ];
+  };
+
+  programs.tarsnap = {
+    enable = true;
+    keyfile = "/home/grfn/.private/tarsnap.key";
+    printStats = true;
+    humanizeNumbers = true;
+  };
+
+  programs.zsh.initExtra = ''
+    [[ ! $IN_NIX_SHELL ]] && alsi -l
+  '';
+}