about summary refs log tree commit diff
path: root/home/platforms/darwin.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
commit9036dc7c32739d302cdd6fe51fe2d01418a99c9d (patch)
tree2f67188616193c8b9b3de011d0bc546aca68a5ee /home/platforms/darwin.nix
parent86b5f58ca51bfb91de4cd29e66b781d5e035db7a (diff)
Beginnings of config for Darwin machines
Split out a platforms/ directory with a linux.nix and darwin.nix, and
starting splitting things out between the two
Diffstat (limited to 'home/platforms/darwin.nix')
-rw-r--r--home/platforms/darwin.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/home/platforms/darwin.nix b/home/platforms/darwin.nix
new file mode 100644
index 000000000000..d6b33ba5625c
--- /dev/null
+++ b/home/platforms/darwin.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+  home.packages = with pkgs; [
+    coreutils
+    gnupg
+    pinentry_mac
+  ];
+
+  home.activation.linkApplications = lib.hm.dag.entryAfter ["writeBoundary"] ''
+    $DRY_RUN_CMD ln -sf $VERBOSE_ARG \
+      ~/.nix-profile/Applications/* ~/Applications/
+  '';
+
+  programs.zsh.initExtra = ''
+    export NIX_PATH=$HOME/.nix-defexpr/channels:$NIX_PATH
+
+    if [[ "$TERM" == "alacritty" ]]; then
+      export TERM="xterm-256color"
+    fi
+  '';
+}