about summary refs log tree commit diff
path: root/home/modules/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T15·28-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T15·28-0400
commit9d6939dc4bcfbbd5652501d7cca6000027ccc219 (patch)
tree6149d2cdadc67b23a0aeef16e8abf9a25f16ba5d /home/modules/shell.nix
parent0275aaec03149b641ef2d6516cad20bddcce6bb5 (diff)
Bat theme
Diffstat (limited to 'home/modules/shell.nix')
-rw-r--r--home/modules/shell.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/home/modules/shell.nix b/home/modules/shell.nix
index 69672473af..dc4580039b 100644
--- a/home/modules/shell.nix
+++ b/home/modules/shell.nix
@@ -74,13 +74,15 @@ let
     "gcan" = "git commit --amend --no-edit";
     "grl" = "git reflog";
 
-    # Aliases from old config
+    # Directories
     stck = "dirs -v";
     b= "cd ~1";
     ".." = "cd ..";
     "..." = "cd ../..";
     "...." = "cd ../../..";
     "....." = "cd ../../../..";
+
+    # Aliases from old config
     "http" = "http --style solarized";
     "grep" = "grep $GREP_OPTIONS";
     "bak" = "~/bin/backup.sh";
@@ -119,6 +121,7 @@ in {
     LS_COLORS = "no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.ogg=01;35:*.mp3=01;35:*.wav=01;35:";
     TWITTER_WHOAMI = "glittershark1";
     BROWSER = "firefox";
+    BAT_THEME = "ansi-light";
   };
 
   programs.bash = {