about summary refs log tree commit diff
path: root/home/modules/i3.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-04-09T03·23-0400
committerGriffin Smith <root@gws.fyi>2020-04-09T03·23-0400
commitbf92d3b7407d306944eca92df2bf49c787546b11 (patch)
treedf0bfdc2099565a0d88e5235810910a310648165 /home/modules/i3.nix
parentfae347ee0f25f26f234d6ec4dc5b4b41897b2996 (diff)
simplify rofi script
Diffstat (limited to 'home/modules/i3.nix')
-rw-r--r--home/modules/i3.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/home/modules/i3.nix b/home/modules/i3.nix
index b4ffd202e0..e3eea5f7d8 100644
--- a/home/modules/i3.nix
+++ b/home/modules/i3.nix
@@ -95,15 +95,13 @@ in {
             ''}";
 
             # Launching applications
-            "${mod}+u" =
-              let rofi = pkgs.writeShellScript "rofi" ''
+            "${mod}+u" = "exec ${pkgs.writeShellScript "rofi" ''
               rofi \
                 -modi 'combi' \
                 -combi-modi "window,drun,ssh,run" \
                 -font '${decorationFont}' \
                 -show combi
-            '';
-              in "exec ${rofi}";
+            ''}";
 
             # Passwords
             "${mod}+p" = "exec rofi-pass -font '${decorationFont}'";