about summary refs log tree commit diff
path: root/home/modules/email.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-29T16·49-0400
committerGriffin Smith <root@gws.fyi>2020-03-29T16·49-0400
commit87909fc5cbbbb3bc29c2c92bd4145f3317d5e945 (patch)
treed3de0d32f38011220a87d355c812ad15d3a4694f /home/modules/email.nix
parent4a049b08b1afd62979d939daef733ed42b0964e2 (diff)
Email module for home
notmuch, lieer
Diffstat (limited to 'home/modules/email.nix')
-rw-r--r--home/modules/email.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/home/modules/email.nix b/home/modules/email.nix
new file mode 100644
index 0000000000..028d6fb982
--- /dev/null
+++ b/home/modules/email.nix
@@ -0,0 +1,53 @@
+{ pkgs, ... }:
+{
+  # programs.mbsync.enable = true;
+  programs.lieer.enable = true;
+  programs.notmuch.enable = true;
+  services.lieer.enable = true;
+  programs.msmtp.enable = true;
+
+  home.packages = with pkgs; [
+    mu
+  ];
+
+  accounts.email.maildirBasePath = "mail";
+  accounts.email.accounts =
+    let
+      mkAccount = params@{ passEntry, ... }: {
+        realName = "Griffin Smith";
+        passwordCommand = "pass ${passEntry}";
+
+        flavor = "gmail.com";
+
+        imapnotify = {
+          enable = true;
+          boxes = [ "Inbox" ];
+        };
+
+        gpg = {
+          key = "0F11A989879E8BBBFDC1E23644EF5B5E861C09A7";
+          signByDefault = true;
+        };
+
+        # mbsync.enable = true;
+        notmuch.enable = true;
+        lieer = {
+          enable = true;
+          sync.enable = true;
+        };
+        msmtp.enable = true;
+      } // builtins.removeAttrs params ["passEntry"];
+    in {
+      work = mkAccount {
+        primary = true;
+        address = "griffin@urbint.com";
+        aliases = [ "grfn@urbint.com" ];
+        passEntry = "urbint/msmtp-app-password";
+      };
+
+      personal = mkAccount {
+        address = "root@gws.fyi";
+        passEntry = "root-gws-msmtp";
+      };
+    };
+}