about summary refs log tree commit diff
path: root/home/modules/emacs.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
commit9036dc7c32739d302cdd6fe51fe2d01418a99c9d (patch)
tree2f67188616193c8b9b3de011d0bc546aca68a5ee /home/modules/emacs.nix
parent86b5f58ca51bfb91de4cd29e66b781d5e035db7a (diff)
Beginnings of config for Darwin machines
Split out a platforms/ directory with a linux.nix and darwin.nix, and
starting splitting things out between the two
Diffstat (limited to 'home/modules/emacs.nix')
-rw-r--r--home/modules/emacs.nix106
1 files changed, 57 insertions, 49 deletions
diff --git a/home/modules/emacs.nix b/home/modules/emacs.nix
index 71d7cbf70e..2a4babf5e1 100644
--- a/home/modules/emacs.nix
+++ b/home/modules/emacs.nix
@@ -1,5 +1,7 @@
 { pkgs, lib, ... }:
 
+with lib;
+
 let
  # doom-emacs = pkgs.callPackage (builtins.fetchTarball {
  #   url = https://github.com/vlaci/nix-doom-emacs/archive/master.tar.gz;
@@ -8,7 +10,7 @@ let
  #                               # and packages.el files
  # };
 in {
-  # imports = [ ./lib/cloneRepo.nix ];
+  imports = [ ./lib/cloneRepo.nix ];
 
   # home.packages = [ doom-emacs ];
   # home.file.".emacs.d/init.el".text = ''
@@ -16,61 +18,67 @@ in {
   # '';
   #
 
-  home.packages = with pkgs; [
-    # haskellPackages.Agda BROKEN
+  config = mkMerge [
+    {
+      home.packages = with pkgs; [
+        haskellPackages.Agda 
 
-    # LaTeX (for org export)
-    (pkgs.texlive.combine {
-      inherit (pkgs.texlive)
-        scheme-basic collection-fontsrecommended ulem
-        fncychap titlesec tabulary varwidth framed fancyvrb float parskip
-        wrapfig upquote capt-of needspace;
-    })
+        # LaTeX (for org export)
+        (pkgs.texlive.combine {
+          inherit (pkgs.texlive)
+          scheme-basic collection-fontsrecommended ulem
+          fncychap titlesec tabulary varwidth framed fancyvrb float parskip
+          wrapfig upquote capt-of needspace;
+        })
 
-    ispell
+        ispell
 
-    ripgrep
-    coreutils
-    fd
-    clang
-    gnutls
-  ];
+        ripgrep
+        coreutils
+        fd
+        clang
+        gnutls
+      ];
 
-  nixpkgs.overlays = [
-    (import (builtins.fetchTarball {
-      url = "https://github.com/nix-community/emacs-overlay/archive/54afb061bdd12c61bbfcc13bad98b7a3aab7d8d3.tar.gz";
-      sha256 = "0hrbg65d5h0cb0nky7a46md7vlvhajq1hf0328l2f7ln9hznqz6j";
-    }))
-  ];
+      nixpkgs.overlays = [
+        (import (builtins.fetchTarball {
+          url = "https://github.com/nix-community/emacs-overlay/archive/54afb061bdd12c61bbfcc13bad98b7a3aab7d8d3.tar.gz";
+          sha256 = "0hrbg65d5h0cb0nky7a46md7vlvhajq1hf0328l2f7ln9hznqz6j";
+        }))
+      ];
 
-  programs.emacs = {
-    enable = true;
-    package = pkgs.emacsUnstable;
-  };
+      programs.emacs = {
+        enable = true;
+        package = pkgs.emacsUnstable;
+      };
 
-  impure.clonedRepos = {
-    orgClubhouse = {
-      github = "glittershark/org-clubhouse";
-      path = "code/org-clubhouse";
-    };
+      impure.clonedRepos = {
+        orgClubhouse = {
+          github = "glittershark/org-clubhouse";
+          path = "code/org-clubhouse";
+        };
 
-    doomEmacs = {
-      github = "hlissner/doom-emacs";
-      path = ".emacs.d";
-      after = ["emacs.d"];
-      onClone = "bin/doom install";
-    };
+        doomEmacs = {
+          github = "hlissner/doom-emacs";
+          path = ".emacs.d";
+          after = ["emacs.d"];
+          onClone = "bin/doom install";
+        };
 
-    "emacs.d" = {
-      github = "glittershark/emacs.d";
-      path = ".doom.d";
-      after = ["orgClubhouse"];
-    };
-  };
+        "emacs.d" = {
+          github = "glittershark/emacs.d";
+          path = ".doom.d";
+          after = ["orgClubhouse"];
+        };
+      };
 
-  # Notes
-  services.syncthing = {
-    enable = true;
-    tray = true;
-  };
+    }
+    (mkIf pkgs.stdenv.isLinux {
+      # Notes
+      services.syncthing = {
+        enable = true;
+        tray = true;
+      };
+    })
+  ];
 }