about summary refs log tree commit diff
path: root/home/modules/development/urbint.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-06-08T14·20-0400
committerGriffin Smith <root@gws.fyi>2020-06-08T14·20-0400
commit0a7b41284df1b7c124197f89935d37f2d902ee98 (patch)
tree8be3ea8034ded5aaca86b724c1104be72f0e0dbd /home/modules/development/urbint.nix
parentf48477cfdb9cbf7d6e185e91af050c5202033911 (diff)
convert hardcoded functions to new functions option
Diffstat (limited to 'home/modules/development/urbint.nix')
-rw-r--r--home/modules/development/urbint.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/home/modules/development/urbint.nix b/home/modules/development/urbint.nix
index 4bf39b656f58..63f92bf50d4e 100644
--- a/home/modules/development/urbint.nix
+++ b/home/modules/development/urbint.nix
@@ -25,16 +25,10 @@ in
       amerge = "alembic merge heads";
     };
 
-    initExtra = ''
-      # Alembic {{{
-      function aup() {
-        alembic upgrade ''${1:-head}
-      }
-
-      function adown() {
-        alembic downgrade ''${1:--1}
-      }
-    '';
+    functions = {
+      aup = "alembic upgrade \${1:-head}";
+      adown = "alembic downgrade \${1:--1}";
+    };
   };
 
   programs.git = {