about summary refs log tree commit diff
path: root/home/modules/development.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-06-04T14·47-0400
committerGriffin Smith <root@gws.fyi>2020-06-04T14·47-0400
commit8f50a550c5afd1a4d1704818053f49437d27c95e (patch)
tree9d5d6d66d20416b859b14f8cbc9324f8d050dc26 /home/modules/development.nix
parent1f38ccf7c0b4992fa5bb75e789662b2ca746e248 (diff)
git aliases to development.nix
Diffstat (limited to 'home/modules/development.nix')
-rw-r--r--home/modules/development.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/home/modules/development.nix b/home/modules/development.nix
index 326193f61444..54a0e6e68469 100644
--- a/home/modules/development.nix
+++ b/home/modules/development.nix
@@ -89,6 +89,52 @@ with lib;
   };
 
   programs.zsh.shellAliases = {
+    # Git
+    "gwip" = "git add . && git commit -am wip";
+    "gpr" = "g pull-request";
+    "gcl" = "git clone";
+    "grs" = "gr --soft";
+    "grhh" = "grh HEAD";
+    "grh" = "gr --hard";
+    "gr" = "git reset";
+    "gcb" = "gc -b";
+    "gco" = "gc";
+    "gcd" = "gc development";
+    "gcm" = "gc master";
+    "gc" = "git checkout";
+    "gbg" = "git branch | grep";
+    "gba" = "git branch -a";
+    "gb" = "git branch";
+    "gcv" = "git commit --verbose";
+    "gci" = "git commit";
+    "gm" = "git merge";
+    "gdc" = "gd --cached";
+    "gd" = "git diff";
+    "gsl" = "git stash list";
+    "gss" = "git show stash";
+    "gsad" = "git stash drop";
+    "gsa" = "git stash";
+    "gst" = "gs";
+    "gs" = "git status";
+    "gg" = "gl --decorate --oneline --graph --date-order --all";
+    "gl" = "git log";
+    "gf" = "git fetch";
+    "gur" = "gu --rebase";
+    "gu" = "git pull";
+    "gpf" = "gp -f";
+    "gpa" = "gp --all";
+    "gpu" = "git push -u origin \"$(git symbolic-ref --short HEAD)\"";
+    "gp" = "git push";
+    "ganw" = "git diff -w --no-color | git apply --cached --ignore-whitespace";
+    "ga" = "git add";
+    "gnp" = "git --no-pager";
+    "g" = "git";
+    "git" = "hub";
+    "grim" = "git fetch && git rebase -i origin/master";
+    "grc" = "git rebase --continue";
+    "gcan" = "git commit --amend --no-edit";
+    "grl" = "git reflog";
+
     # Haskell
     "cnb" = "cabal new-build";
     "cob" = "cabal old-build";