about summary refs log tree commit diff
path: root/home/modules/development.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
commit9036dc7c32739d302cdd6fe51fe2d01418a99c9d (patch)
tree2f67188616193c8b9b3de011d0bc546aca68a5ee /home/modules/development.nix
parent86b5f58ca51bfb91de4cd29e66b781d5e035db7a (diff)
Beginnings of config for Darwin machines
Split out a platforms/ directory with a linux.nix and darwin.nix, and
starting splitting things out between the two
Diffstat (limited to 'home/modules/development.nix')
-rw-r--r--home/modules/development.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/home/modules/development.nix b/home/modules/development.nix
index 3417b21261..5e17a7a925 100644
--- a/home/modules/development.nix
+++ b/home/modules/development.nix
@@ -1,5 +1,7 @@
 { config, lib, pkgs, ... }:
 
+with lib;
+
 {
   imports = [
     ./development/kube.nix
@@ -21,14 +23,14 @@
       rev = "9e7279edde2a4e0f5ec04c53f5cd64440a27a1ae";
       sha256 = "0zz2lrwn3y3rb8gzaiwxgz02dvy3s552zc70zvfqc0zh5dhydgn7";
     }) { inherit pkgs; }).yarn2nix
-    julia
     (pkgs.callPackage (pkgs.fetchFromGitHub {
       owner = "hlolli";
       repo = "clj2nix";
       rev = "3ab3480a25e850b35d1f532a5e4e7b3202232383";
       sha256 = "1lry026mlpxp1j563qs13nhxf37i2zpl7lh0lgfdwc44afybqka6";
     }) {})
-  ];
+  ] ++ 
+  optional (stdenv.isLinux) julia;
 
   programs.git = {
     enable = true;