about summary refs log tree commit diff
path: root/home/home.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-04T17·17-0400
committerGriffin Smith <root@gws.fyi>2020-05-04T17·17-0400
commitd22a0381a5f8d9c52d251d3a8e6be08adeb89e4e (patch)
tree71c3a60dd97052c8e416a2b982543bdd8a9db015 /home/home.nix
parent976ff9bbd3a9eef8d8051d617ef7099f3e0c6390 (diff)
git config is in development
Diffstat (limited to 'home/home.nix')
-rw-r--r--home/home.nix45
1 files changed, 16 insertions, 29 deletions
diff --git a/home/home.nix b/home/home.nix
index 42f155362e..af289c8d0b 100644
--- a/home/home.nix
+++ b/home/home.nix
@@ -13,9 +13,11 @@ let machine = ./machines/chupacabra.nix; in
     ./modules/shell.nix
     ./modules/tarsnap.nix
     ./modules/vim.nix
-    ./modules/alsi.nix
+
     ./modules/lib/cloneRepo.nix
 
+    ./modules/urbint
+
     machine
   ];
 
@@ -47,6 +49,9 @@ let machine = ./machines/chupacabra.nix; in
     peek
     signal-desktop
     apvlv # pdf viewer
+    vlc
+    irssi
+    gnutls
 
     # System utilities
     htop
@@ -60,18 +65,12 @@ let machine = ./machines/chupacabra.nix; in
     zip
     tree
     ncat
+    unzip
 
     # Security
     gnupg
-
-    # Programming
-    jq
-    gitAndTools.hub
-    gitAndTools.tig
-    shellcheck
-    httpie
-    entr
-    gnumake
+    keybase
+    openssl
 
     # Spotify...etc
     spotify
@@ -87,25 +86,6 @@ let machine = ./machines/chupacabra.nix; in
 
   nixpkgs.config.allowUnfree = true;
 
-  programs.git = {
-    enable = true;
-    userEmail = "root@gws.fyi";
-    userName  = "Griffin Smith";
-    ignores = [
-      "*.sw*"
-      ".classpath"
-      ".project"
-      ".settings/"
-      ".dir-locals.el"
-      ".stack-work-profiling"
-      ".projectile"
-    ];
-    extraConfig = {
-      github.user = "glittershark";
-      merge.conflictstyle = "diff3";
-    };
-  };
-
   programs.password-store.enable = true;
 
   services.redshift = {
@@ -125,4 +105,11 @@ let machine = ./machines/chupacabra.nix; in
   services.gpg-agent = {
     enable = true;
   };
+
+  gtk = {
+    enable = true;
+    gtk3.bookmarks = [
+      "file:///home/grfn/code"
+    ];
+  };
 }