about summary refs log tree commit diff
path: root/home/home.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-29T16·51-0400
committerGriffin Smith <root@gws.fyi>2020-03-29T16·51-0400
commit3f1cff7068d012e5b9a56f9d61659be5172aa987 (patch)
treec86677dffdfa8b8fd906c6eb2ed260e2bbb06ee0 /home/home.nix
parent87909fc5cbbbb3bc29c2c92bd4145f3317d5e945 (diff)
lots of extra packages, misc home config
Diffstat (limited to 'home/home.nix')
-rw-r--r--home/home.nix41
1 files changed, 38 insertions, 3 deletions
diff --git a/home/home.nix b/home/home.nix
index 77499a32ba..402456e8a4 100644
--- a/home/home.nix
+++ b/home/home.nix
@@ -28,13 +28,28 @@
   home.stateVersion = "19.09";
 
   home.packages = with pkgs; [
-    nix-prefetch-github
+    # Desktop stuff
+    arandr
+    firefox
+    chromium
+    xclip
+    xorg.xev
+
+    # System utilities
     htop
     powertop
-    pass
+    usbutils
+    killall
+
+    # Security
+    gnupg
+
+    # Programming
+    jq
     gitAndTools.hub
+    gitAndTools.tig
     shellcheck
-    gnupg
+    httpie
 
     # Spotify...etc
     spotify
@@ -43,6 +58,9 @@
     # games
     crawl
     dwarf-fortress
+
+    # Nix things
+    nix-prefetch-github
   ];
 
   nixpkgs.config.allowUnfree = true;
@@ -51,8 +69,13 @@
     enable = true;
     userEmail = "root@gws.fyi";
     userName  = "Griffin Smith";
+    extraConfig = {
+      github.user = "glittershark";
+    };
   };
 
+  programs.password-store.enable = true;
+
   services.redshift = {
     enable = true;
     provider = "geoclue2";
@@ -68,4 +91,16 @@
   services.gpg-agent = {
     enable = true;
   };
+
+  xdg.mimeApps = {
+    enable = true;
+    defaultApplications = {
+      "text/html" = [ "firefox.desktop" ];
+    };
+  };
+  };
+
+  services.gpg-agent = {
+    enable = true;
+  };
 }