about summary refs log tree commit diff
path: root/haskell-overlay.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-01-05T04·48-0500
committerGriffin Smith <root@gws.fyi>2020-01-05T04·48-0500
commit6b0bab0e85266ce66836c4584f8cc83b307a3af5 (patch)
treecfb4dbe4c370c3f20277336e6be75171c572137a /haskell-overlay.nix
parente669b54f0c9be84dd1e4704ccae4b8169f7458a5 (diff)
Add support for multiple levels
Add a data structure, based on the zipper comonad, which provides
support for multiple levels, each of which is its own entity map. The
current level is provided by coreturn, which the `entities` lens has
been updated to use. Nothing currently supports going up or down levels
yet - that's coming next.
Diffstat (limited to 'haskell-overlay.nix')
-rw-r--r--haskell-overlay.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/haskell-overlay.nix b/haskell-overlay.nix
index d3775316ad..fff1c21741 100644
--- a/haskell-overlay.nix
+++ b/haskell-overlay.nix
@@ -29,4 +29,7 @@ in self: super: with pkgs.haskell.lib; rec {
       };
       version = "0.12.0";
     };
+
+  comonad-extras = appendPatch (markUnbroken super.comonad-extras)
+    [ ./build/update-comonad-extras.patch ];
 }