about summary refs log tree commit diff
path: root/haskell-file/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-18T11·00+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commit0c71fc9d1d49daa914c0f56f4f9201d40415d9b4 (patch)
tree3c8a4b894065e64111c20d06026b63db17259c65 /haskell-file/shell.nix
parent51ec9e0d88b15276ec0891f932f6b572d6450809 (diff)
Drop support for dir-locals.nix, <nixpkgs>, etc.
In the spirit of Marie Kondo, I'm tidying up!

TL;DR:
- Prefer .envrc `use_nix` and delete all dir-locals.nix files
- Remove ~all references to <nixpkgs>, <unstable>, <depot> and prefer
  referencing each with briefcase.third_party.{pkgs,unstable,depot}
- Delete nixBufferFromShell function since I was only using that in
  dir-locals.nix files
Diffstat (limited to 'haskell-file/shell.nix')
-rw-r--r--haskell-file/shell.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/haskell-file/shell.nix b/haskell-file/shell.nix
index f2621d6eac5a..4d5b412a0884 100644
--- a/haskell-file/shell.nix
+++ b/haskell-file/shell.nix
@@ -1,9 +1,5 @@
-with import <nixpkgs> {};
-
-stdenv.mkDerivation {
-  name = "f-hs";
-  buildInputs = [
-    (pkgs.haskellPackages.ghcWithPackages (pkgs: [
-    ]))
-  ];
+let
+  briefcase = import <briefcase> {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: [];
 }