about summary refs log tree commit diff
path: root/haskell-file/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-15T14·29+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-15T14·29+0000
commit8d00a456a03aed5dc4a8944519e4d3d44c446ad8 (patch)
tree58ea1c24116fa19d5fda3d14d5914ca6d864dd4e /haskell-file/shell.nix
parentd4d8397e5ffe6734ed5861e48ce475848956a3fe (diff)
Beging work to port f.el to Haskell
This is a work-in-progress. I'd like to add a README to this project to explain
my intention. The goal, roughly, is to port Elisp's fantastic f.el module to
Haskell. I consider Haskell APIs to be useful but somewhat sloppily designed. In
the same spirit as Elixir wrapping Erlang APIs, many of the functions I intend
to define will simply wrap existing Haskell APIs, but with a hopefully cleaner
API that I find more intuitive.
Diffstat (limited to 'haskell-file/shell.nix')
-rw-r--r--haskell-file/shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/haskell-file/shell.nix b/haskell-file/shell.nix
new file mode 100644
index 0000000000..f2621d6eac
--- /dev/null
+++ b/haskell-file/shell.nix
@@ -0,0 +1,9 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+  name = "f-hs";
+  buildInputs = [
+    (pkgs.haskellPackages.ghcWithPackages (pkgs: [
+    ]))
+  ];
+}