about summary refs log tree commit diff
path: root/gopkgs/utils/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-09T13·47+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-10T10·06+0000
commit64654d1d6d1f36a20e00ee6cdc3866ff009c3a0a (patch)
tree3a764c88197e704a86ef527467b49a933c9f242d /gopkgs/utils/default.nix
parentec4c8472ca8eaed9a40d5decf5f909bdda96ec62 (diff)
Create gopkgs directory for golang libs
- Created a gopkgs directory and registered it with default.nix's readTree
- Moved monzo_ynab/utils -> gopkgs
- Consumed utils.go in main.go
- Renamed monzo_ynab -> job
Diffstat (limited to 'gopkgs/utils/default.nix')
-rw-r--r--gopkgs/utils/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/gopkgs/utils/default.nix b/gopkgs/utils/default.nix
new file mode 100644
index 0000000000..d92b82ca4d
--- /dev/null
+++ b/gopkgs/utils/default.nix
@@ -0,0 +1,11 @@
+{
+  depot ? import <depot> {},
+  ...
+}:
+
+depot.buildGo.package {
+  name = "utils";
+  srcs = [
+    ./utils.go
+  ];
+}