about summary refs log tree commit diff
path: root/go/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-09T01·02+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-10T10·06+0000
commit2d3428c8096c27c0c499f0c89ef92b8c306b644e (patch)
tree219a212e751d9f6b38aeaa7f8519a5f03e07ccba /go/shell.nix
parent2af05f698c583bb71f318352e1da3b9ae2d1ae31 (diff)
Practice concurrency in golang
Uploading some snippets I created to help me better understand concurrency in
general and specifically concurrency in golang.
Diffstat (limited to 'go/shell.nix')
-rw-r--r--go/shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/go/shell.nix b/go/shell.nix
new file mode 100644
index 000000000000..836718d85f29
--- /dev/null
+++ b/go/shell.nix
@@ -0,0 +1,9 @@
+{ pkgs ? import <nixpkgs> {}, ... }:
+
+pkgs.mkShell {
+  buildInputs = [
+    pkgs.go
+    pkgs.goimports
+    pkgs.godef
+  ];
+}