about summary refs log tree commit diff
path: root/fun/wcl/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-28T21·06+0000
committerVincent Ambo <tazjin@google.com>2020-01-28T21·07+0000
commit1ba3d1cf97b9f671c7e0572fad7c57d691e69444 (patch)
tree64f7e8d1a482c5c37ef2b664dc2e9ec8f75b872a /fun/wcl/default.nix
parent176b3458b0352975dfa1af7eac5cb90a5394a4ba (diff)
feat(fun/wcl): Add a simple 'wc' clone in Lisp r/469
Prompted by this thread:
https://lobste.rs/s/zntyeq/wc_d_712_characters_without_single_branch
Diffstat (limited to 'fun/wcl/default.nix')
-rw-r--r--fun/wcl/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/fun/wcl/default.nix b/fun/wcl/default.nix
new file mode 100644
index 0000000000..17367f3d80
--- /dev/null
+++ b/fun/wcl/default.nix
@@ -0,0 +1,13 @@
+{ pkgs, ... }:
+
+pkgs.nix.buildLisp.program {
+  name = "wc";
+
+  srcs = [
+    ./wc.lisp
+  ];
+
+  deps = with pkgs.third_party.lisp; [
+    iterate
+  ];
+}