about summary refs log tree commit diff
path: root/fun/idual/setup.py
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-04-25T21·17+0100
committerVincent Ambo <tazjin@google.com>2020-04-25T21·17+0100
commite7aaa0bc2f3d1c1f7514076f990ece7adebcdace (patch)
treebf6c378ac703847ee8dd946fdfb5dbaed4f07e31 /fun/idual/setup.py
parenteac683f69cbc301bc122144de397d9f52bd39359 (diff)
feat(fun/idual): Move colour codes into a Python script r/685
This will make them easier to consume for the thing I'm actually
trying to do here.
Diffstat (limited to '')
-rw-r--r--fun/idual/setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/fun/idual/setup.py b/fun/idual/setup.py
new file mode 100644
index 0000000000..b218b07f78
--- /dev/null
+++ b/fun/idual/setup.py
@@ -0,0 +1,16 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+from setuptools import setup, find_packages
+
+setup(
+    name='idualctl',
+    version='0.1',
+    author='Vincent Ambo',
+    author_email='mail@tazj.in',
+    url='https://git.tazj.in/about/fun/idual',
+    packages=['idual'],
+    package_dir = {'idual': ''},
+    scripts = ['idual.py'],
+    install_requires=['broadlink>=0.13.2'],
+    include_package_data=True,
+)