about summary refs log tree commit diff
path: root/fun/dt/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-08T17·55+0100
committerVincent Ambo <tazjin@google.com>2020-05-08T17·55+0100
commite33627f960c767c7408a4885a0061ade2703c9f9 (patch)
tree781e936efd78f7856ef33dcedb5b98d7789c9fd8 /fun/dt/default.nix
parent28a36a2b70e31f9b8bf90085cf1b70fe038e9ff6 (diff)
feat(fun/dt): Implement useful utility r/707
Diffstat (limited to 'fun/dt/default.nix')
-rw-r--r--fun/dt/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/fun/dt/default.nix b/fun/dt/default.nix
new file mode 100644
index 0000000000..4dbf00ede1
--- /dev/null
+++ b/fun/dt/default.nix
@@ -0,0 +1,14 @@
+{ depot, pkgs, ... }:
+
+let
+  stdenv = with pkgs; overrideCC clangStdenv clang_9;
+  abseil-cpp = pkgs.abseil-cpp.override { inherit stdenv; };
+in stdenv.mkDerivation {
+  name = "dt";
+  src = ./.;
+  nativeBuildInputs = [ pkgs.cmake ];
+  buildInputs = with pkgs; [
+    abseil-cpp
+    farmhash
+  ];
+}