about summary refs log tree commit diff
path: root/fun/dt/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-08T17·55+0100
committerVincent Ambo <tazjin@google.com>2020-05-08T17·55+0100
commite33627f960c767c7408a4885a0061ade2703c9f9 (patch)
tree781e936efd78f7856ef33dcedb5b98d7789c9fd8 /fun/dt/CMakeLists.txt
parent28a36a2b70e31f9b8bf90085cf1b70fe038e9ff6 (diff)
feat(fun/dt): Implement useful utility r/707
Diffstat (limited to 'fun/dt/CMakeLists.txt')
-rw-r--r--fun/dt/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/fun/dt/CMakeLists.txt b/fun/dt/CMakeLists.txt
new file mode 100644
index 0000000000..85b659fea8
--- /dev/null
+++ b/fun/dt/CMakeLists.txt
@@ -0,0 +1,16 @@
+# -*- mode: cmake; -*-
+cmake_minimum_required(VERSION 3.16)
+project(dt)
+add_executable(dt dt.cc)
+find_package(absl REQUIRED)
+
+target_link_libraries(dt
+  absl::flags
+  absl::flags_parse
+  absl::hash
+  absl::time
+  absl::strings
+  farmhash
+)
+
+install(TARGETS dt DESTINATION bin)