about summary refs log tree commit diff
path: root/fun/amsterdump/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <Vincent Ambo>2020-01-05T21·09+0000
committerVincent Ambo <Vincent Ambo>2020-01-05T21·10+0000
commit7b77e9986c5bbedce6bc0a0154d253f71c9f2548 (patch)
treef28545c7409984057f792e8530a99f180de28e01 /fun/amsterdump/default.nix
parentb8ca70539b8f3ec8dc05ea1d0a806307d54b2e3c (diff)
feat(fun/amsterdump): Add distance matrix lookup for fundu results r/337
This contains a little tool that can make requests to the Google Maps
API for distance matrix lookups from Fundu results to Schiphol Airport
and Amsterdam Centraal.

<3 edef!
Diffstat (limited to 'fun/amsterdump/default.nix')
-rw-r--r--fun/amsterdump/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/fun/amsterdump/default.nix b/fun/amsterdump/default.nix
new file mode 100644
index 0000000000..e5fc22a176
--- /dev/null
+++ b/fun/amsterdump/default.nix
@@ -0,0 +1,13 @@
+{ pkgs, ... }:
+
+pkgs.buildGo.program {
+  name = "amsterdump";
+  srcs = [
+    ./main.go
+  ];
+
+  deps = with pkgs.third_party; map (p: p.gopkg) [
+    # gopkgs."golang.org".x.oauth2.google
+    gopkgs."googlemaps.github.io".maps
+  ];
+}