about summary refs log tree commit diff
path: root/finito-postgres/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2018-09-26T14·53+0200
committerVincent Ambo <mail@tazj.in>2018-09-26T14·54+0200
commitb1e00ff0264fec4f3a5b87470980aebd94db81cf (patch)
treecd1774471f252d6443ded48aba56f7392e5dce16 /finito-postgres/Cargo.toml
parentc03e14758f53eeeecfe8067dd2eff9e9d32c1edd (diff)
feat(postgres): Bootstrap Postgres persistence implementation
Adds the initial finito-postgres crate with type definitions for the
tables and initial functions to interact with persisted FSMs.

This is far from feature complete at this commit.
Diffstat (limited to 'finito-postgres/Cargo.toml')
-rw-r--r--finito-postgres/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/finito-postgres/Cargo.toml b/finito-postgres/Cargo.toml
new file mode 100644
index 000000000000..c9f8476dbdc6
--- /dev/null
+++ b/finito-postgres/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "finito-postgres"
+version = "0.1.0"
+authors = ["Vincent Ambo <vincent@aprila.no>"]
+
+[dependencies]
+chrono = "0.4"
+serde = "1.0"
+serde_json = "1.0"
+postgres-derive = "0.3"
+
+[dependencies.postgres]
+version = "0.15"
+features = [ "with-uuid", "with-chrono", "with-serde_json" ]
+
+[dependencies.uuid]
+version = "0.5"
+features = [ "v4" ]
+
+[dependencies.finito]
+path = "../finito-core"