about summary refs log tree commit diff
path: root/finito-door/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2018-09-26T21·18+0200
committerVincent Ambo <mail@tazj.in>2018-09-26T21·18+0200
commitc4b94d8d2dc00c0742cf7af1c0fd2c1256f75078 (patch)
tree6d9a7cbd32de151fb007969b533dd58180c71ba2 /finito-door/Cargo.toml
parent37590ae0f61187f080fe5b09d037ad428b4b1db4 (diff)
feat(door): Use failure::Error as associated error type
Implements the associated error type for the FSM trait as
failure::Error. This makes it possible to fail gracefully in all
actions, for example in the updated definition of the `NotifyIRC`
action which now appends to a file.
Diffstat (limited to 'finito-door/Cargo.toml')
-rw-r--r--finito-door/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/finito-door/Cargo.toml b/finito-door/Cargo.toml
index ad1cf22d4229..d632d110855a 100644
--- a/finito-door/Cargo.toml
+++ b/finito-door/Cargo.toml
@@ -4,6 +4,7 @@ version = "0.1.0"
 authors = ["Vincent Ambo <vincent@aprila.no>"]
 
 [dependencies]
+failure = "0.1"
 serde = "1.0"
 serde_derive = "1.0"