about summary refs log tree commit diff
path: root/example/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-07-15T07·20+0100
committerVincent Ambo <mail@tazj.in>2020-07-15T07·20+0100
commit7f19d641647ac4ef313ed88d6b5c140983ce5436 (patch)
tree31b66c81465293da5c093c5dde3e419758c0d6cc /example/CMakeLists.txt
Squashed 'third_party/immer/' content from commit ad3e3556d
git-subtree-dir: third_party/immer
git-subtree-split: ad3e3556d38bb75966dd24c61a774970a7c7957e
Diffstat (limited to 'example/CMakeLists.txt')
-rw-r--r--example/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
new file mode 100644
index 000000000000..2aa0f554279d
--- /dev/null
+++ b/example/CMakeLists.txt
@@ -0,0 +1,17 @@
+
+#  Targets
+#  =======
+
+add_custom_target(examples
+  COMMENT "Build all examples.")
+add_dependencies(check examples)
+
+file(GLOB_RECURSE immer_examples "*.cpp")
+foreach(_file IN LISTS immer_examples)
+  immer_target_name_for(_target _output "${_file}")
+  add_executable(${_target} EXCLUDE_FROM_ALL "${_file}")
+  add_dependencies(examples ${_target})
+  set_target_properties(${_target} PROPERTIES OUTPUT_NAME ${_output})
+  target_link_libraries(${_target} PUBLIC immer-dev)
+  add_test("example/${_output}" ${_output})
+endforeach()