about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-09-02T13·05+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-09-02T13·07+0100
commit9c71c78abcdaa4ce46aaee964494659d5283e5d6 (patch)
tree200cbbbb6e0073312e43b6e87bcfe4eeaf2b22bd /emacs/default.nix
parentc17796a60dba0c81ffb03ad277063a7eee2e1736 (diff)
Pull Emacs 27 from @tazjin's depot
Here's what happened:

My `emacs.glinux` derivation relies on gLinux `/usr/bin/emacs`, and Google
recently published version 27, so all corporate machines (i.e. this laptop)
switched from Emacs 26 to Emacs 27 overnight.

However, my Nix derivation was building all of the packages for Emacs 26, so
some packages were compatible while others weren't.

The Elisp package, `emr`, doesn't build for version 27, so I dropped it
altogether.
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index c6b1403299..685a37ec2b 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -1,8 +1,9 @@
-{ pkgs, ... }:
+{ pkgs, depot, ... }:
 
 let
   inherit (builtins) path;
-  inherit (pkgs) emacs26 emacsPackagesNgGen writeShellScript writeShellScriptBin;
+  inherit (depot.third_party) emacsPackagesGen emacs27;
+  inherit (pkgs) writeShellScript writeShellScriptBin;
   inherit (pkgs.lib.strings) makeBinPath;
 
   emacsBinPath = makeBinPath (with pkgs; [
@@ -17,7 +18,7 @@ let
     xorg.xset
   ]);
 
-  emacsWithPackages = (emacsPackagesNgGen emacs26).emacsWithPackages;
+  emacsWithPackages = (emacsPackagesGen emacs27).emacsWithPackages;
 
   wpcarrosEmacs = emacsWithPackages (epkgs:
     (with epkgs.elpaPackages; [
@@ -32,6 +33,7 @@ let
       ts
       vterm
       base16-theme
+      password-store
       ivy-pass
       clipmon # TODO: Prefer an Emacs client for clipmenud.
       protobuf-mode # TODO: Determine if this is coming from google-emacs.
@@ -57,7 +59,6 @@ let
       parsec
       magit-popup
       direnv
-      emr
       ivy-prescient
       all-the-icons
       all-the-icons-ivy
@@ -109,7 +110,6 @@ let
       counsel
       flycheck
       ivy
-      magit
     ]));
 
   vendorDir = path {